aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorWladimir J. van der Laan <laanwj@gmail.com>2013-11-20 14:18:57 +0100
committerWladimir J. van der Laan <laanwj@gmail.com>2013-11-27 06:00:29 +0100
commitfb78cc23784b2fa478324aac35ca76c7cfe683a4 (patch)
tree85b9ec58146c64dbb52b1bcd1fea938055be7500 /src/Makefile.am
parent03b6a1cee4fe7f38ca16c0bc2d08d8d4d1288f2f (diff)
downloadbitcoin-fb78cc23784b2fa478324aac35ca76c7cfe683a4.tar.xz
Split up bitcoinrpc (code movement only)
Split bitcoinrpc up into - rpcserver: bitcoind RPC server - rpcclient: bitcoin-cli RPC client - rpcprotocol: shared common HTTP/JSON-RPC protocol code One step towards making bitcoin-cli independent from the rest of the code, and thus a smaller executable that doesn't have to be linked against leveldb. This commit only does code movement, there are no functional changes.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am11
1 files changed, 9 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 7450507b34..561d2ca7ae 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -12,7 +12,10 @@ DIST_SUBDIRS = . qt test
.PHONY: FORCE
# bitcoin core #
BITCOIN_CORE_H = addrman.h alert.h allocators.h base58.h bignum.h \
- bitcoinrpc.h bloom.h chainparams.h checkpoints.h checkqueue.h \
+ rpcclient.h \
+ rpcprotocol.h \
+ rpcserver.h \
+ bloom.h chainparams.h checkpoints.h checkqueue.h \
clientversion.h coincontrol.h compat.h core.h coins.h crypter.h db.h hash.h init.h \
key.h keystore.h leveldbwrapper.h limitedmap.h main.h miner.h mruset.h \
netbase.h net.h noui.h protocol.h script.h serialize.h sync.h threadsafety.h \
@@ -30,7 +33,11 @@ obj/build.h: FORCE
$(abs_top_srcdir)
version.o: obj/build.h
-libbitcoin_a_SOURCES = addrman.cpp alert.cpp allocators.cpp bitcoinrpc.cpp bloom.cpp \
+libbitcoin_a_SOURCES = addrman.cpp alert.cpp allocators.cpp \
+ rpcclient.cpp \
+ rpcprotocol.cpp \
+ rpcserver.cpp \
+ bloom.cpp \
chainparams.cpp checkpoints.cpp core.cpp coins.cpp crypter.cpp db.cpp hash.cpp \
init.cpp key.cpp keystore.cpp leveldbwrapper.cpp main.cpp miner.cpp \
netbase.cpp net.cpp noui.cpp protocol.cpp rpcblockchain.cpp rpcdump.cpp \