aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorWladimir J. van der Laan <laanwj@gmail.com>2015-05-15 13:54:32 +0200
committerWladimir J. van der Laan <laanwj@gmail.com>2015-05-15 13:59:07 +0200
commite47c94e64c44e817ac80cf682a68ba0c4580952f (patch)
treeee2c59e0e8d3344673bcba76e2adeacec00b41a8 /src/Makefile.am
parentf0043c2d6d2ceddd631a76b424dd8c163f3dad66 (diff)
parentf13dac972c9cf308abf72a1d1a54135b1392eaea (diff)
downloadbitcoin-e47c94e64c44e817ac80cf682a68ba0c4580952f.tar.xz
Merge pull request #6135
f13dac9 Comment edits and cleanup (BitcoinPRReadingGroup) ff734e9 Alphabetic order in makefile (Jorge Timón) 5207f33 fix header include groups (Philip Kaufmann) 59b149f remove unneeded incude of wallet/db.h from rpcmining.cpp (Philip Kaufmann) 3703385 remove unused classes from db.h (Philip Kaufmann) 0a7bcb7 fix IDE/compiler warning "extra ';'" in validationinterface.h (Philip Kaufmann) 3b00e7c [Trivial] Update COPYING (sandakersmann) dd9e688 Trivial: Corrected owner of DNS seeder (ayeowch) a60bfd8 [init] better message when no wallet support is compiled in (Philip Kaufmann) 78f44b6 Capitalized P2P (sandakersmann) 8e9248d [Trivial] Cryptocurrency is one word (sandakersmann) 803f51e Typo in GetRawMemPool RPC method help: "]" --> "}" (Chris Arnesen) 605a735 addrman: update comments (Pavel Vasin)
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am48
1 files changed, 24 insertions, 24 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 91d530222f..93ad26acf8 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -77,8 +77,8 @@ BITCOIN_CORE_H = \
base58.h \
bloom.h \
chain.h \
- chainparamsbase.h \
chainparams.h \
+ chainparamsbase.h \
chainparamsseeds.h \
checkpoints.h \
checkqueue.h \
@@ -86,11 +86,13 @@ BITCOIN_CORE_H = \
coincontrol.h \
coins.h \
compat.h \
+ compat/byteswap.h \
+ compat/endian.h \
+ compat/sanity.h \
compressor.h \
consensus/consensus.h \
consensus/params.h \
core_io.h \
- wallet/db.h \
eccryptoverify.h \
ecwrapper.h \
hash.h \
@@ -104,8 +106,8 @@ BITCOIN_CORE_H = \
merkleblock.h \
miner.h \
mruset.h \
- netbase.h \
net.h \
+ netbase.h \
noui.h \
policy/fees.h \
pow.h \
@@ -119,8 +121,8 @@ BITCOIN_CORE_H = \
rpcserver.h \
scheduler.h \
script/interpreter.h \
- script/script_error.h \
script/script.h \
+ script/script_error.h \
script/sigcache.h \
script/sign.h \
script/standard.h \
@@ -146,12 +148,10 @@ BITCOIN_CORE_H = \
validationinterface.h \
version.h \
wallet/crypter.h \
- wallet/walletdb.h \
+ wallet/db.h \
wallet/wallet.h \
wallet/wallet_ismine.h \
- compat/byteswap.h \
- compat/endian.h \
- compat/sanity.h
+ wallet/walletdb.h
JSON_H = \
json/json_spirit.h \
@@ -218,39 +218,37 @@ libbitcoin_wallet_a_SOURCES = \
# crypto primitives library
crypto_libbitcoin_crypto_a_CPPFLAGS = $(BITCOIN_CONFIG_INCLUDES)
crypto_libbitcoin_crypto_a_SOURCES = \
- crypto/sha1.cpp \
- crypto/sha256.cpp \
- crypto/sha512.cpp \
- crypto/hmac_sha256.cpp \
- crypto/hmac_sha512.cpp \
- crypto/ripemd160.cpp \
crypto/common.h \
- crypto/sha256.h \
- crypto/sha512.h \
+ crypto/hmac_sha256.cpp \
crypto/hmac_sha256.h \
+ crypto/hmac_sha512.cpp \
crypto/hmac_sha512.h \
+ crypto/ripemd160.cpp \
+ crypto/ripemd160.h \
+ crypto/sha1.cpp \
crypto/sha1.h \
- crypto/ripemd160.h
+ crypto/sha256.cpp \
+ crypto/sha256.h \
+ crypto/sha512.cpp \
+ crypto/sha512.h
# univalue JSON library
univalue_libbitcoin_univalue_a_SOURCES = \
univalue/univalue.cpp \
- univalue/univalue_read.cpp \
- univalue/univalue_write.cpp \
+ univalue/univalue.h \
univalue/univalue_escapes.h \
- univalue/univalue.h
+ univalue/univalue_read.cpp \
+ univalue/univalue_write.cpp
# common: shared between bitcoind, and bitcoin-qt and non-server tools
libbitcoin_common_a_CPPFLAGS = $(BITCOIN_INCLUDES)
libbitcoin_common_a_SOURCES = \
- arith_uint256.cpp \
amount.cpp \
+ arith_uint256.cpp \
base58.cpp \
chainparams.cpp \
coins.cpp \
compressor.cpp \
- primitives/block.cpp \
- primitives/transaction.cpp \
core_read.cpp \
core_write.cpp \
eccryptoverify.cpp \
@@ -259,14 +257,16 @@ libbitcoin_common_a_SOURCES = \
key.cpp \
keystore.cpp \
netbase.cpp \
+ primitives/block.cpp \
+ primitives/transaction.cpp \
protocol.cpp \
pubkey.cpp \
scheduler.cpp \
script/interpreter.cpp \
script/script.cpp \
+ script/script_error.cpp \
script/sign.cpp \
script/standard.cpp \
- script/script_error.cpp \
$(BITCOIN_CORE_H)
# util: shared between all executables.