aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorGavin Andresen <gavinandresen@gmail.com>2013-10-09 16:45:59 +1000
committerGavin Andresen <gavinandresen@gmail.com>2013-10-09 16:48:53 +1000
commitd8315d1650373e6609cfda921160fd51f6608a99 (patch)
tree70a5dcccf893486bbd69dc4357021310a9d6bdb0 /src/Makefile.am
parent26002aa444d4ee4986d623e0ad45cca02e803bc5 (diff)
downloadbitcoin-d8315d1650373e6609cfda921160fd51f6608a99.tar.xz
Remove include of windows.h from allocators.h
Create an allocators.cpp, and move all of the #ifdef WIN32 code and the #include of windows.h into it. Two motives for this cleanup: 1. I'm getting a weird error in windows.h in my smartfee branch. 2. allocators.h is included (indirectly) just about everywhere, so this should speed up Windows compiles quite a lot.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index c0687ae2e6..49249fedc7 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -31,7 +31,7 @@ obj/build.h: FORCE
$(abs_top_srcdir)
version.o: obj/build.h
-libbitcoin_a_SOURCES = addrman.cpp alert.cpp bitcoinrpc.cpp bloom.cpp \
+libbitcoin_a_SOURCES = addrman.cpp alert.cpp allocators.cpp bitcoinrpc.cpp bloom.cpp \
chainparams.cpp checkpoints.cpp core.cpp crypter.cpp db.cpp hash.cpp \
init.cpp key.cpp keystore.cpp leveldb.cpp main.cpp miner.cpp \
netbase.cpp net.cpp noui.cpp protocol.cpp rpcblockchain.cpp rpcdump.cpp \