aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorWladimir J. van der Laan <laanwj@gmail.com>2014-01-21 08:52:52 +0100
committerWladimir J. van der Laan <laanwj@gmail.com>2014-01-21 08:55:07 +0100
commita682bc7e46f5a269fd8b6f58bdbe73384f6c76aa (patch)
treea9f1760e66b5ab730ad1d3ec25f7ade6d4e709b4 /src/Makefile.am
parent1ab310e7df58476b4ad7242c190810315f40e6a2 (diff)
parent2041365c8c2d0f8e83715b2a643c3fd2cf6eb4cb (diff)
downloadbitcoin-a682bc7e46f5a269fd8b6f58bdbe73384f6c76aa.tar.xz
Merge pull request #3242
2041365 Bugfix: Use BOOST_CPPFLAGS when testing for boost sleep vs sleep_for (Luke Dashjr) e18e100 configure: Minor grammatical changes to be more clear (Luke Dashjr) a9dbcf0 configure: Change --with[out]-qt to --with[out]-gui and add --with[out]-cli and --with[out]-daemon to support more build configurations (Luke Dashjr) f472990 Bugfix: Correct captitalisation of Qt (Luke Dashjr) f930341 configure: Internal changes to make building bitcoind and bitcoin-cli optional (Luke Dashjr) 4a290b5 Cleanup LevelDB library dependencies (Luke Dashjr) 9b4e03b Bugfix: Undefine _FORTIFY_SOURCE before redefining it, to avoid warnings on compilers that define it by default (Luke Dashjr) 123e4f8 Bugfix: configure: Allow user-provided CXXFLAGS to override default optimisation, debug, and warning flags (Luke Dashjr)
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am18
1 files changed, 13 insertions, 5 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 9917be2481..f27f16ab91 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,7 +1,6 @@
include Makefile.include
-AM_CPPFLAGS += -I$(top_srcdir)/src/leveldb/helpers/memenv \
- -I$(builddir)
+AM_CPPFLAGS += -I$(builddir)
noinst_LIBRARIES = \
libbitcoin_server.a \
@@ -11,7 +10,15 @@ if ENABLE_WALLET
noinst_LIBRARIES += libbitcoin_wallet.a
endif
-bin_PROGRAMS = bitcoind bitcoin-cli
+bin_PROGRAMS =
+
+if BUILD_BITCOIND
+ bin_PROGRAMS += bitcoind
+endif
+
+if BUILD_BITCOIN_CLI
+ bin_PROGRAMS += bitcoin-cli
+endif
SUBDIRS = . $(BUILD_QT) $(BUILD_TEST)
DIST_SUBDIRS = . qt test
@@ -140,8 +147,8 @@ bitcoind_LDADD = \
libbitcoin_server.a \
libbitcoin_cli.a \
libbitcoin_common.a \
- leveldb/libleveldb.a \
- leveldb/libmemenv.a
+ $(LIBLEVELDB) \
+ $(LIBMEMENV)
if ENABLE_WALLET
bitcoind_LDADD += libbitcoin_wallet.a
endif
@@ -167,6 +174,7 @@ if TARGET_WINDOWS
bitcoin_cli_SOURCES += bitcoin-cli-res.rc
endif
+# NOTE: This dependency is not strictly necessary, but without it make may try to build both in parallel, which breaks the LevelDB build system in a race
leveldb/libleveldb.a: leveldb/libmemenv.a
leveldb/%.a: