aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorDaniel Cousens <github@dcousens.com>2016-01-15 11:55:17 +1100
committerDaniel Cousens <github@dcousens.com>2016-01-21 08:36:55 +1100
commita0eaff8a1d18ebba33cdea4cd1efaddeb55519e7 (patch)
tree5f13a0b8968d60274d86c44b685c9c980f7a33ca /src/Makefile.am
parentb92ea98503e64ea6ddc5c04b879e59b1755d5efc (diff)
downloadbitcoin-a0eaff8a1d18ebba33cdea4cd1efaddeb55519e7.tar.xz
move rpc* to rpc/
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am22
1 files changed, 11 insertions, 11 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 948d12424f..9a6b4fd66b 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -131,9 +131,9 @@ BITCOIN_CORE_H = \
pubkey.h \
random.h \
reverselock.h \
- rpcclient.h \
- rpcprotocol.h \
- rpcserver.h \
+ rpc/client.h \
+ rpc/protocol.h \
+ rpc/server.h \
scheduler.h \
script/interpreter.h \
script/script.h \
@@ -203,12 +203,12 @@ libbitcoin_server_a_SOURCES = \
policy/policy.cpp \
pow.cpp \
rest.cpp \
- rpcblockchain.cpp \
- rpcmining.cpp \
- rpcmisc.cpp \
- rpcnet.cpp \
- rpcrawtransaction.cpp \
- rpcserver.cpp \
+ rpc/blockchain.cpp \
+ rpc/mining.cpp \
+ rpc/misc.cpp \
+ rpc/net.cpp \
+ rpc/rawtransaction.cpp \
+ rpc/server.cpp \
script/sigcache.cpp \
timedata.cpp \
torcontrol.cpp \
@@ -304,7 +304,7 @@ libbitcoin_util_a_SOURCES = \
compat/glibcxx_sanity.cpp \
compat/strnlen.cpp \
random.cpp \
- rpcprotocol.cpp \
+ rpc/protocol.cpp \
support/cleanse.cpp \
sync.cpp \
uint256.cpp \
@@ -322,7 +322,7 @@ endif
libbitcoin_cli_a_CPPFLAGS = $(AM_CPPFLAGS) $(BITCOIN_INCLUDES)
libbitcoin_cli_a_CXXFLAGS = $(AM_CXXFLAGS) $(PIE_FLAGS)
libbitcoin_cli_a_SOURCES = \
- rpcclient.cpp \
+ rpc/client.cpp \
$(BITCOIN_CORE_H)
nodist_libbitcoin_util_a_SOURCES = $(srcdir)/obj/build.h