aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorJonas Schnelli <dev@jonasschnelli.ch>2015-10-01 13:01:58 +0200
committerJonas Schnelli <dev@jonasschnelli.ch>2015-10-01 14:28:44 +0200
commit95acf3cc6d90d9406030ce897efdee8be0550a53 (patch)
treea92fc9e9b94c44439b3b205b94607ea68259f650 /src/Makefile.am
parent9623e934732ba0f0a5176cd3d993ebcda327b413 (diff)
downloadbitcoin-95acf3cc6d90d9406030ce897efdee8be0550a53.tar.xz
remove $(@F) and subdirs from univalue make
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 301880dbc3..462774389a 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -36,8 +36,8 @@ LIBUNIVALUE=univalue/lib/libunivalue.la
$(LIBSECP256K1): $(wildcard secp256k1/src/*) $(wildcard secp256k1/include/*)
$(AM_V_at)$(MAKE) $(AM_MAKEFLAGS) -C $(@D) $(@F)
-$(LIBUNIVALUE): $(wildcard univalue/lib/*) $(wildcard univalue/include/*)
- $(AM_V_at)$(MAKE) $(AM_MAKEFLAGS) -C $(@D) $(@F)
+$(LIBUNIVALUE): $(wildcard univalue/lib/*)
+ $(AM_V_at)$(MAKE) $(AM_MAKEFLAGS) -C univalue/
# Make is not made aware of per-object dependencies to avoid limiting building parallelization
# But to build the less dependent modules first, we manually select their order here: