aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorLuke Dashjr <luke-jr+git@utopios.org>2013-09-07 19:43:25 +0000
committerLuke Dashjr <luke-jr+git@utopios.org>2013-09-10 22:26:00 +0000
commit941dba17838a1a40f5a5862eb2f84ffec511911e (patch)
treef75825c12d05bc4d4a78207edd72073d865e5e4a /src/Makefile.am
parentb4d8d03b86405193e79310231a2d7ce3b636d554 (diff)
downloadbitcoin-941dba17838a1a40f5a5862eb2f84ffec511911e.tar.xz
configure: Check common include subdirectories for bdb headers, and refuse to use any version other than 4.8 by default
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 3697b9ff22..3499784234 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -47,6 +47,9 @@ bitcoind_LDADD = libbitcoin.a leveldb/libleveldb.a leveldb/libmemenv.a \
bitcoind_SOURCES = bitcoind.cpp
#
+AM_CPPFLAGS += $(BDB_CPPFLAGS)
+bitcoind_LDADD += $(BDB_LIBS)
+
leveldb/libleveldb.a:
@echo "Building LevelDB ..." && cd leveldb && CXX="$(CXX)" CC="$(CC)" \
PLATFORM=$(TARGET_OS) AR="$(AR)" $(MAKE) $(LEVELDB_TARGET_FLAGS) OPT="$(CXXFLAGS) $(CPPFLAGS)" libleveldb.a