aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorGavin Andresen <gavinandresen@gmail.com>2015-04-02 10:33:45 -0400
committerGavin Andresen <gavinandresen@gmail.com>2015-05-14 10:37:19 -0400
commit928b950e3b0622cca48a9eb2106dc7c006fbe520 (patch)
tree9abb734c3b47545af14db7ccaa91aa66b4318e3b /src/Makefile.am
parente656560edb287171b754a9a9c569a3f1cb1a7853 (diff)
downloadbitcoin-928b950e3b0622cca48a9eb2106dc7c006fbe520.tar.xz
CScheduler class for lightweight task scheduling
Simple class to manage a task queue that is serviced by one or more threads.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 72d79619b2..5349e18fc1 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -115,6 +115,7 @@ BITCOIN_CORE_H = \
rpcclient.h \
rpcprotocol.h \
rpcserver.h \
+ scheduler.h \
script/interpreter.h \
script/script_error.h \
script/script.h \
@@ -257,6 +258,7 @@ libbitcoin_common_a_SOURCES = \
netbase.cpp \
protocol.cpp \
pubkey.cpp \
+ scheduler.cpp \
script/interpreter.cpp \
script/script.cpp \
script/sign.cpp \