aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorCory Fields <cory-nospam-@coryfields.com>2014-07-08 15:53:53 -0400
committerCory Fields <cory-nospam-@coryfields.com>2014-07-08 15:53:53 -0400
commit575e70c0c6c14058e4fc6c37f4e4d52399b69432 (patch)
tree9d51ca75d595279519c4205fdc81d0db4ac0592f /src/Makefile.am
parent9a427da116b9bf9b49e17590173b2848f4dbedf5 (diff)
downloadbitcoin-575e70c0c6c14058e4fc6c37f4e4d52399b69432.tar.xz
build: fix win32 static linking after libtool merge
Libtool eats the -static flag rather than passing it along to the compiler. To get the same effect, -all-static is used instead.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index e2a62c9699..9b0b97b7ac 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,5 +1,5 @@
AM_CPPFLAGS = $(INCLUDES)
-AM_LDFLAGS = $(PTHREAD_CFLAGS)
+AM_LDFLAGS = $(PTHREAD_CFLAGS) $(LIBTOOL_LDFLAGS)
if USE_LIBSECP256K1
secp256k1/libsecp256k1.la: $(wildcard secp256k1/src/*) $(wildcard secp256k1/include/*)