aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorCory Fields <cory-nospam-@coryfields.com>2014-06-09 14:58:30 -0400
committerPieter Wuille <pieter.wuille@gmail.com>2014-06-21 19:47:43 +0200
commit54372482a8ffa363f5dd9ff1c80141a168109ed5 (patch)
treee7141e96b50b6dcc0fbb3f0a118208dfa580b6d2 /src/Makefile.am
parent3820e01eb9ad0e502e92ebc44cb4623cf4f3d4c4 (diff)
downloadbitcoin-54372482a8ffa363f5dd9ff1c80141a168109ed5.tar.xz
build: move bitcoin-config.h to its own directory
This allows us to include its path without making other header includes valid.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 01655b7011..c666fb7662 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -17,7 +17,8 @@ $(LIBLEVELDB) $(LIBMEMENV):
OPT="$(CXXFLAGS) $(CPPFLAGS)"
endif
-BITCOIN_INCLUDES=-I$(builddir) -I$(builddir)/obj $(BOOST_CPPFLAGS) $(LEVELDB_CPPFLAGS)
+BITCOIN_CONFIG_INCLUDES=-I$(builddir)/config
+BITCOIN_INCLUDES=-I$(builddir) -I$(builddir)/obj $(BITCOIN_CONFIG_INCLUDES) $(BOOST_CPPFLAGS) $(LEVELDB_CPPFLAGS)
noinst_LIBRARIES = \
libbitcoin_server.a \
@@ -219,6 +220,7 @@ EXTRA_DIST = leveldb
clean-local:
-$(MAKE) -C leveldb clean
rm -f leveldb/*/*.gcno leveldb/helpers/memenv/*.gcno
+ -rm -f config.h
.rc.o:
@test -f $(WINDRES)