aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorJonas Schnelli <jonas.schnelli@include7.ch>2015-02-03 21:09:47 +0100
committerJonas Schnelli <jonas.schnelli@include7.ch>2015-03-12 14:13:02 +0100
commit50c72f23ad5f7fcd13bf016f79cac6323c329caf (patch)
tree2ea49700ab27d3e9705f7a035f1a5783beed4ca2 /src/Makefile.am
parente564e63ef04e55b1e446f8440d51c611bc41cec6 (diff)
downloadbitcoin-50c72f23ad5f7fcd13bf016f79cac6323c329caf.tar.xz
[Move Only] Move wallet related things to src/wallet/
could once be renamed from /src/wallet to /src/legacywallet.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am20
1 files changed, 10 insertions, 10 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index da65efa713..c30368c5bf 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -90,7 +90,7 @@ BITCOIN_CORE_H = \
compressor.h \
core_io.h \
crypter.h \
- db.h \
+ wallet/db.h \
eccryptoverify.h \
ecwrapper.h \
hash.h \
@@ -138,9 +138,9 @@ BITCOIN_CORE_H = \
utilstrencodings.h \
utiltime.h \
version.h \
- walletdb.h \
- wallet.h \
- wallet_ismine.h \
+ wallet/walletdb.h \
+ wallet/wallet.h \
+ wallet/wallet_ismine.h \
compat/byteswap.h \
compat/endian.h \
compat/sanity.h
@@ -196,13 +196,13 @@ libbitcoin_server_a_SOURCES = \
# when wallet enabled
libbitcoin_wallet_a_CPPFLAGS = $(BITCOIN_INCLUDES)
libbitcoin_wallet_a_SOURCES = \
- db.cpp \
+ wallet/db.cpp \
crypter.cpp \
- rpcdump.cpp \
- rpcwallet.cpp \
- wallet.cpp \
- wallet_ismine.cpp \
- walletdb.cpp \
+ wallet/rpcdump.cpp \
+ wallet/rpcwallet.cpp \
+ wallet/wallet.cpp \
+ wallet/wallet_ismine.cpp \
+ wallet/walletdb.cpp \
$(BITCOIN_CORE_H)
# crypto primitives library