aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorWladimir J. van der Laan <laanwj@gmail.com>2017-11-16 09:01:19 +0100
committerWladimir J. van der Laan <laanwj@gmail.com>2017-11-16 09:33:10 +0100
commit3c098a8aa0780009c11b66b1a5d488a928629ebf (patch)
tree9199f290ff331a5f8bc1d2ba1a29e9fd236eefe3 /src/Makefile.am
parent54aedc013744c86b11157423fa3cffc9a51eef02 (diff)
parent7b91b5f8a4417da1940956c1ab32dba94dc104e1 (diff)
downloadbitcoin-3c098a8aa0780009c11b66b1a5d488a928629ebf.tar.xz
Merge #11651: refactor: Make all #includes relative to project root (laanwj, MeshCollider, ryanofsky)
7b91b5f Remove trailing whitespace causing travis failure (MeshCollider) 434f5a2 Recommend #include<> syntax in developer notes (Russell Yanofsky) 96b9281 refactor: Include obj/build.h instead of build.h (Wladimir J. van der Laan) 138016b test: refactor: Use absolute include paths for test data files (Wladimir J. van der Laan) e7b3163 qt: refactor: Changes to make include paths absolute (Wladimir J. van der Laan) 0c71521 build: Remove -I for everything but project root (Wladimir J. van der Laan) 5b56ec9 qt: refactor: Use absolute include paths in .ui files (Wladimir J. van der Laan) 1a44534 scripted-diff: Replace #include "" with #include <> (ryanofsky) (MeshCollider) Pull request description: Rebase of #11053 Previously started by @laanwj, ACK'ed by promag, ryanofsky, jonasschnelli, and concept-ACK'ed by practicalswift and jnewbery. Thus should be almost RTM :) Tree-SHA512: d8d25248309deb06a54686c4a6bafd290ba69dcd0df391a50d1caed2c22ff2659be442459bdd9d1fc3b6a1360ba0804a907b1402d206df3e1cb6e8924e3c7f3e
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 3e43076878..29e4ae56d0 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -18,7 +18,7 @@ else
LIBUNIVALUE = $(UNIVALUE_LIBS)
endif
-BITCOIN_INCLUDES=-I$(builddir) -I$(builddir)/obj $(BDB_CPPFLAGS) $(BOOST_CPPFLAGS) $(LEVELDB_CPPFLAGS) $(CRYPTO_CFLAGS) $(SSL_CFLAGS)
+BITCOIN_INCLUDES=-I$(builddir) $(BDB_CPPFLAGS) $(BOOST_CPPFLAGS) $(LEVELDB_CPPFLAGS) $(CRYPTO_CFLAGS) $(SSL_CFLAGS)
BITCOIN_INCLUDES += -I$(srcdir)/secp256k1/include
BITCOIN_INCLUDES += $(UNIVALUE_CFLAGS)