aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorJim Posen <jimpo@coinbase.com>2017-12-08 10:19:57 -0800
committerJim Posen <jimpo@coinbase.com>2018-04-25 11:25:07 -0700
commit34d68bf3a3db2b78c07180416949bbc58bd0b682 (patch)
treeb283962424bb5097ba4f4218dad2f9a6bb1ef3a9 /src/Makefile.am
parentc88bcec93fa8b969e65b1fe7716bda429276bbd4 (diff)
downloadbitcoin-34d68bf3a3db2b78c07180416949bbc58bd0b682.tar.xz
[index] Create new TxIndex class.
The TxIndex will be responsible for building the transaction index concurrently with the main validation thread by implementing ValidationInterface. This does not process blocks concurrently yet.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 521687eb45..0466d961c3 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -103,6 +103,7 @@ BITCOIN_CORE_H = \
fs.h \
httprpc.h \
httpserver.h \
+ index/txindex.h \
indirectmap.h \
init.h \
interfaces/handler.h \
@@ -204,6 +205,7 @@ libbitcoin_server_a_SOURCES = \
consensus/tx_verify.cpp \
httprpc.cpp \
httpserver.cpp \
+ index/txindex.cpp \
init.cpp \
dbwrapper.cpp \
merkleblock.cpp \