aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorCory Fields <cory-nospam-@coryfields.com>2014-10-12 23:28:58 -0400
committerCory Fields <cory-nospam-@coryfields.com>2014-10-13 21:21:27 -0400
commit28d412ff20309b275da1375839dae0ee236a5ac2 (patch)
tree7178eb725ccec50ab1555d85e75142d24a373d4a /src/Makefile.am
parentd7e195048342afae9168377cebfc22ab000728a5 (diff)
downloadbitcoin-28d412ff20309b275da1375839dae0ee236a5ac2.tar.xz
build: quit abusing LIBS for Windows builds.
Similar to the INCLUDES changes in 6b099402b40, split out LIBS into individual entries for more fine-grained control. Also add MINIUPNPC_LIBS which was missing before, and hook it up to executables.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am9
1 files changed, 6 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 155adfef7d..42ecda155c 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -281,7 +281,7 @@ if TARGET_WINDOWS
bitcoind_SOURCES += bitcoind-res.rc
endif
-bitcoind_LDADD += $(BOOST_LIBS) $(BDB_LIBS) $(SSL_LIBS) $(CRYPTO_LIBS)
+bitcoind_LDADD += $(BOOST_LIBS) $(BDB_LIBS) $(SSL_LIBS) $(CRYPTO_LIBS) $(MINIUPNPC_LIBS)
bitcoind_CPPFLAGS = $(BITCOIN_INCLUDES)
bitcoind_LDFLAGS = $(RELDFLAGS) $(AM_LDFLAGS)
@@ -293,7 +293,8 @@ bitcoin_cli_LDADD = \
$(LIBBITCOIN_CRYPTO) \
$(BOOST_LIBS) \
$(SSL_LIBS) \
- $(CRYPTO_LIBS)
+ $(CRYPTO_LIBS) \
+ $(MINIUPNPC_LIBS)
bitcoin_cli_SOURCES = \
bitcoin-cli.cpp
@@ -317,7 +318,9 @@ endif
bitcoin_tx_LDADD += $(BOOST_LIBS) \
$(SSL_LIBS) \
- $(CRYPTO_LIBS)
+ $(CRYPTO_LIBS) \
+ $(MINIUPNPC_LIBS)
+
bitcoin_tx_SOURCES = bitcoin-tx.cpp
bitcoin_tx_CPPFLAGS = $(BITCOIN_INCLUDES)
#