aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorAndrew Chow <achow101-github@achow101.com>2017-06-12 12:23:02 -0700
committerAndrew Chow <achow101-github@achow101.com>2018-02-17 11:42:00 -0500
commit1e79c055cd30d21ba5f8c7f81ef911d5d4e295a8 (patch)
tree22c28017f71d4f9b0dddb77cc41e733095ec84a2 /src/Makefile.am
parent8a98dfeebf58b8fc9b7c966ae0f99ad0760d7800 (diff)
downloadbitcoin-1e79c055cd30d21ba5f8c7f81ef911d5d4e295a8.tar.xz
Split signrawtransaction into wallet and non-wallet
Splits signrwatransaction into a wallet version (signrawtransactionwithwallet) and non-wallet version (signrawtransactionwithkey). signrawtransaction is marked as DEPRECATED and will call the right signrawtransaction* command as per the parameters in order to maintain compatibility. Updated signrawtransactions test to use new RPCs
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 9ca2b2c82a..ac822d6c5e 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -132,6 +132,7 @@ BITCOIN_CORE_H = \
rpc/protocol.h \
rpc/safemode.h \
rpc/server.h \
+ rpc/rawtransaction.h \
rpc/register.h \
rpc/util.h \
scheduler.h \