aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorWladimir J. van der Laan <laanwj@gmail.com>2017-10-04 15:07:38 +0200
committerWladimir J. van der Laan <laanwj@gmail.com>2017-10-04 15:35:41 +0200
commit167cef8082e25e3ebbcd602814f3012772d49d16 (patch)
treeba02ba2641471de99bf5e79fc27766ad525494f2 /src/Makefile.am
parent74123eabdd917f84852eaafbfaed240f4daa8643 (diff)
parentf35d03336994688c7419f9d3547336e356bd2818 (diff)
downloadbitcoin-167cef8082e25e3ebbcd602814f3012772d49d16.tar.xz
Merge #11435: build: Make "make clean" remove all files created when running "make check"
f35d033 build: Make "make clean" remove all files created when running "make check" (practicalswift) Pull request description: Make `make clean` remove all files created when running `make check`. More specifically: remove also `obj/build.h` and `bench/data/block413567.raw.h` as part of `make clean`. Before this patch: ```bash $ git clone https://github.com/bitcoin/bitcoin.git $ cd bitcoin/ $ ./autogen.sh $ ./configure $ cp -r ../bitcoin ../bitcoin-before-make $ make check $ make clean $ cp -r ../bitcoin ../bitcoin-after-make-and-make-clean $ cd .. $ diff -rq bitcoin-before-make/ bitcoin-after-make-and-make-clean/ | grep -E "^Only in bitcoin-after-make-and-make-clean/" | grep -v dirstamp Only in bitcoin-after-make-and-make-clean/src/bench/data: block413567.raw.h Only in bitcoin-after-make-and-make-clean/src/obj: build.h $ ``` After this patch: ```bash $ git clone https://github.com/bitcoin/bitcoin.git $ cd bitcoin/ $ ./autogen.sh $ ./configure $ cp -r ../bitcoin ../bitcoin-before-make $ make check $ make clean $ cp -r ../bitcoin ../bitcoin-after-make-and-make-clean $ cd .. $ diff -rq bitcoin-before-make/ bitcoin-after-make-and-make-clean/ | grep -E "^Only in bitcoin-after-make-and-make-clean/" | grep -v dirstamp $ ``` Tree-SHA512: 953e8423485ffd415f0ade6abe0b4c407454f67c332140ef019d89db425bb4a831327b3f634b8d69b17325dcfc6e3ac72dc2ba1ce5462158eecc3c05645e93ba
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am3
1 files changed, 1 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index c71e457ebe..90deff48b0 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -476,8 +476,7 @@ CLEANFILES += univalue/*.gcda univalue/*.gcno
CLEANFILES += wallet/*.gcda wallet/*.gcno
CLEANFILES += wallet/test/*.gcda wallet/test/*.gcno
CLEANFILES += zmq/*.gcda zmq/*.gcno
-
-DISTCLEANFILES = obj/build.h
+CLEANFILES += obj/build.h
EXTRA_DIST = $(CTAES_DIST)