aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMarcoFalke <falke.marco@gmail.com>2018-04-07 15:19:43 -0400
committerMarcoFalke <falke.marco@gmail.com>2018-04-07 15:19:47 -0400
commit048ac8326b6952244f6e4453f4f8f6ab423eb926 (patch)
tree632ba085b32184b09e7f1658965479741d210845 /src/Makefile.am
parentbecd8dd2ec514f766ee13ac0c01cc74429b966b7 (diff)
parent17780d6f35a3951f649c3b7766b9283d9c18e39f (diff)
downloadbitcoin-048ac8326b6952244f6e4453f4f8f6ab423eb926.tar.xz
Merge #12906: Avoid `interface` keyword to fix windows gitian build
17780d6f35 scripted-diff: Avoid `interface` keyword to fix windows gitian build (Russell Yanofsky) Pull request description: Rename `interface` to `interfaces` Build failure reported by ken2812221 in https://github.com/bitcoin/bitcoin/pull/10244#issuecomment-379434756 Tree-SHA512: e02c97c728540f344202c13b036f9f63af23bd25e25ed7a5cfe9e2c2f201a12ff232cc94a93fbe37ef6fb6bf9e036fe62210ba798ecd30de191d09338754a8d0
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am12
1 files changed, 6 insertions, 6 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index d2cfdc104b..f82248fbed 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -105,9 +105,9 @@ BITCOIN_CORE_H = \
httpserver.h \
indirectmap.h \
init.h \
- interface/handler.h \
- interface/node.h \
- interface/wallet.h \
+ interfaces/handler.h \
+ interfaces/node.h \
+ interfaces/wallet.h \
key.h \
key_io.h \
keystore.h \
@@ -248,7 +248,7 @@ endif
libbitcoin_wallet_a_CPPFLAGS = $(AM_CPPFLAGS) $(BITCOIN_INCLUDES)
libbitcoin_wallet_a_CXXFLAGS = $(AM_CXXFLAGS) $(PIE_FLAGS)
libbitcoin_wallet_a_SOURCES = \
- interface/wallet.cpp \
+ interfaces/wallet.cpp \
wallet/crypter.cpp \
wallet/db.cpp \
wallet/feebumper.cpp \
@@ -361,8 +361,8 @@ libbitcoin_util_a_SOURCES = \
compat/glibcxx_sanity.cpp \
compat/strnlen.cpp \
fs.cpp \
- interface/handler.cpp \
- interface/node.cpp \
+ interfaces/handler.cpp \
+ interfaces/node.cpp \
random.cpp \
rpc/protocol.cpp \
rpc/util.cpp \