aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorAndrew Chow <achow101-github@achow101.com>2018-03-05 16:29:37 -0500
committerAndrew Chow <achow101-github@achow101.com>2018-03-13 12:39:17 -0400
commit0185939be6f7c5554b864e33657ce610fd434e18 (patch)
tree638323d15efce6c4768ea6c79d41ab3cd1a50925 /src/Makefile.am
parentf84fed8eb6a8518a54a997044e55332dd37e223d (diff)
downloadbitcoin-0185939be6f7c5554b864e33657ce610fd434e18.tar.xz
Implement Branch and Bound coin selection in a new file
Create a new file for coin selection logic and implement the BnB algorithm in it.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 0a9370c85c..7c2fe56d9d 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -172,6 +172,7 @@ BITCOIN_CORE_H = \
wallet/wallet.h \
wallet/walletdb.h \
wallet/walletutil.h \
+ wallet/coinselection.h \
warnings.h \
zmq/zmqabstractnotifier.h \
zmq/zmqconfig.h\
@@ -253,6 +254,7 @@ libbitcoin_wallet_a_SOURCES = \
wallet/wallet.cpp \
wallet/walletdb.cpp \
wallet/walletutil.cpp \
+ wallet/coinselection.cpp \
$(BITCOIN_CORE_H)
# crypto primitives library