aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorWladimir J. van der Laan <laanwj@gmail.com>2018-04-08 17:57:22 +0200
committerWladimir J. van der Laan <laanwj@gmail.com>2018-04-08 18:13:49 +0200
commit97785863e2faa4a6d4e1130e300011985df0858c (patch)
tree786d40d6722e49fa007387719f113a07601a5b20 /src/Makefile.am
parent15c3bb4268f3366c26a1ba28d32216f2ff86fe7f (diff)
parent9272d70536287d4ff9aa1ee41a401465c0e8194a (diff)
downloadbitcoin-97785863e2faa4a6d4e1130e300011985df0858c.tar.xz
Merge #12886: Introduce Span type and use it instead of FLATDATA
9272d70 Support serializing Span<unsigned char> and use that instead of FLATDATA (Pieter Wuille) 833bc08 Add Slice: a (pointer, size) array view that acts like a container (Pieter Wuille) Pull request description: Introduce a new data type `Span`, which is an encapsulated pointer + size (like C++20's `std::span` or LevelDB's `Slice`), and represents a view to a sequence of objects laid out continuously in memory. The immediate use case is replacing the remaining `FLATDATA` invocations. Instead of those, we support serializing/deserializing unsigned char `Span`s (treating them as arrays). A longer term goal for `Span`s is making the script execution operate on them rather than on `CScript` itself. This will allow separate storage mechanisms for scripts. Tree-SHA512: 7b0da3c802e5df367f223275004d16b04262804c007b7c73fda927176f0a9c3b2ef3225fa842cb73500b0df73175ec1419f1f5239de2402e21dd9ae8e5d05233
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index f82248fbed..1bbb92bf42 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -316,6 +316,7 @@ libbitcoin_consensus_a_SOURCES = \
script/script_error.cpp \
script/script_error.h \
serialize.h \
+ span.h \
tinyformat.h \
uint256.cpp \
uint256.h \