aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorBen Woosley <ben.woosley@gmail.com>2018-07-12 00:39:40 -0400
committerBen Woosley <ben.woosley@gmail.com>2018-07-17 13:56:21 -0400
commit33539cb34b8f59b65387c142a46744fc83d3ed31 (patch)
treeda44a7b47dcba82cb74aaa4652b14ee153a41d77 /src/Makefile.am
parent6fcdb5ebdd71b8b0fed3df0fd6aa3639bcb87a0b (diff)
downloadbitcoin-33539cb34b8f59b65387c142a46744fc83d3ed31.tar.xz
Extract MakeUnique into utilmemory.h
And use it to reduce chainparamsbase's direct reliance on util.h to only args handling. utilmemory.h can be replaced with <memory> once we move to C++14.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 1dd202085a..2603dbae56 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -179,6 +179,7 @@ BITCOIN_CORE_H = \
ui_interface.h \
undo.h \
util.h \
+ utilmemory.h \
utilmoneystr.h \
utiltime.h \
validation.h \