aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorWladimir J. van der Laan <laanwj@gmail.com>2017-03-27 12:14:43 +0200
committerWladimir J. van der Laan <laanwj@gmail.com>2017-03-27 12:21:35 +0200
commite6dcfeec05d6527ab148550836937ff435e6449c (patch)
tree08be69b20b3acb139378636597e938c5864696f1 /src/Makefile.am
parent5114f8113627791b871c88998bd5a3d36961c241 (diff)
downloadbitcoin-e6dcfeec05d6527ab148550836937ff435e6449c.tar.xz
refactor: Move GetDifficulty out of `rpc/server.h`
It has no business in `rpcserver.h`. Define it in the interface header of the implementation unit `rpcblockchain` where it is defined. Also modernize the signature to: double GetDifficulty(const CBlockIndex* blockindex = nullptr); (remove `extern`, replace `NULL` with `nullptr`)
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 8a32156884..30d027315a 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -122,6 +122,7 @@ BITCOIN_CORE_H = \
protocol.h \
random.h \
reverselock.h \
+ rpc/blockchain.h \
rpc/client.h \
rpc/protocol.h \
rpc/server.h \