aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorWladimir J. van der Laan <laanwj@gmail.com>2017-01-04 12:20:43 +0100
committerWladimir J. van der Laan <laanwj@gmail.com>2017-01-04 12:21:53 +0100
commitd9ae1cefa081c7ef978fab0b288475692678af72 (patch)
treeaaafc90d4a0ef9a6ac14f6787a4d8852705e095f /src/Makefile.am
parentc0ddd32bf629bb48426b0651def497ca1a78e6b1 (diff)
parent67ee4ec9015592c8447955356adfcbb1bf473e32 (diff)
downloadbitcoin-d9ae1cefa081c7ef978fab0b288475692678af72.tar.xz
Merge #9289: net: drop boost::thread_group
67ee4ec net: misc header cleanups (Cory Fields) 8b3159e net: make proxy receives interruptible (Cory Fields) 5cb0fce net: remove thread_interrupted catch (Cory Fields) d3d7056 net: make net processing interruptible (Cory Fields) 0985052 net: make net interruptible (Cory Fields) 799df91 net: add CThreadInterrupt and InterruptibleSleep (Cory Fields) 7325b15 net: a few small cleanups before replacing boost threads (Cory Fields)
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 89b90e6dff..3428d4613d 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -138,6 +138,7 @@ BITCOIN_CORE_H = \
support/lockedpool.h \
sync.h \
threadsafety.h \
+ threadinterrupt.h \
timedata.h \
torcontrol.h \
txdb.h \
@@ -327,6 +328,7 @@ libbitcoin_util_a_SOURCES = \
rpc/protocol.cpp \
support/cleanse.cpp \
sync.cpp \
+ threadinterrupt.cpp \
util.cpp \
utilmoneystr.cpp \
utilstrencodings.cpp \