aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorJorge Timón <jtimon@jtimon.cc>2015-11-23 17:34:42 +0100
committerJorge Timón <jtimon@jtimon.cc>2015-12-08 06:31:04 +0100
commitcf82d05dd45b0e8c97a70deb2d539c02b03d1917 (patch)
treeeffe466d23c09664df0d89885c81ec288759acf7 /src/Makefile.am
parent4feadec98e0b610d1272c398505e41962218bc4f (diff)
downloadbitcoin-cf82d05dd45b0e8c97a70deb2d539c02b03d1917.tar.xz
Build: Consensus: Make libbitcoinconsensus_la_SOURCES fully dynamic and dependend on both crypto and consensus packages
Some extra bytes in libconsensus to get all the crypto (except for signing, which is in the common module) below the libconsensus future independent repo (that has libsecp256k1 as a subtree). hmac_sha256.o seems to be the only thing libbitcoinconsensus doesn't depend on from crypto, some more bytes for the final libconsensus: I'm not personally worried.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am8
1 files changed, 1 insertions, 7 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 502bbd8311..726cc0c30e 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -408,13 +408,7 @@ bitcoin_tx_LDADD += $(BOOST_LIBS) $(CRYPTO_LIBS)
# bitcoinconsensus library #
if BUILD_BITCOIN_LIBS
include_HEADERS = script/bitcoinconsensus.h
-libbitcoinconsensus_la_SOURCES = \
- crypto/hmac_sha512.cpp \
- crypto/ripemd160.cpp \
- crypto/sha1.cpp \
- crypto/sha256.cpp \
- crypto/sha512.cpp \
- $(libbitcoin_consensus_a_SOURCES)
+libbitcoinconsensus_la_SOURCES = $(crypto_libbitcoin_crypto_a_SOURCES) $(libbitcoin_consensus_a_SOURCES)
if GLIBC_BACK_COMPAT
libbitcoinconsensus_la_SOURCES += compat/glibc_compat.cpp