aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorSuhas Daftuar <sdaftuar@chaincode.com>2015-12-16 14:57:54 -0500
committerSuhas Daftuar <sdaftuar@gmail.com>2016-01-19 08:30:04 -0500
commiteaa8d2754b48b62cdd07255fc3028feecad0c095 (patch)
treeb8d312d93e9ec123af0ba08034ab5df18ce6f2e7 /src/Makefile.am
parentf9fd4c2884849bc667da3da8bf5f78f33dd01f1c (diff)
downloadbitcoin-eaa8d2754b48b62cdd07255fc3028feecad0c095.tar.xz
RPC: indicate which transactions are replaceable
Add "bip125-replaceable" output field to listtransactions and gettransaction which indicates if an unconfirmed transaction, or any unconfirmed parent, is signaling opt-in RBF according to BIP 125.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 5da1a873de..5d7fbb13d2 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -122,6 +122,7 @@ BITCOIN_CORE_H = \
noui.h \
policy/fees.h \
policy/policy.h \
+ policy/rbf.h \
pow.h \
prevector.h \
primitives/block.h \
@@ -239,6 +240,7 @@ libbitcoin_wallet_a_SOURCES = \
wallet/wallet.cpp \
wallet/wallet_ismine.cpp \
wallet/walletdb.cpp \
+ policy/rbf.cpp \
$(BITCOIN_CORE_H)
# crypto primitives library