aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorWladimir J. van der Laan <laanwj@gmail.com>2017-01-05 11:10:40 +0100
committerWladimir J. van der Laan <laanwj@gmail.com>2017-01-05 11:11:17 +0100
commitcfe41d7a6034158eda76f6344406373786decb0e (patch)
treea59ee53337e0d00d068c99f53379c5f55529febd /src/Makefile.am
parentc4b7d4f79c85bef332858579698f3ec7fd36f68b (diff)
parent05a55a639b6cd01b06be285db53edccdaf2ca189 (diff)
downloadbitcoin-cfe41d7a6034158eda76f6344406373786decb0e.tar.xz
Merge #9387: [Refactor] RAII of libevent stuff using unique ptrs with deleters
05a55a6 Added EVENT_CFLAGS to test makefile to explicitly include libevent headers. (Karl-Johan Alm) 280a559 Added some simple tests for the RAII-style events. (Karl-Johan Alm) 7f7f102 Switched bitcoin-cli.cpp to use RAII unique pointers with deleters. (Karl-Johan Alm) e5534d2 Added std::unique_ptr<> wrappers with deleters for libevent modules. (Karl-Johan Alm)
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 3428d4613d..a2072865a3 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -135,6 +135,7 @@ BITCOIN_CORE_H = \
support/allocators/secure.h \
support/allocators/zeroafterfree.h \
support/cleanse.h \
+ support/events.h \
support/lockedpool.h \
sync.h \
threadsafety.h \