aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorWladimir J. van der Laan <laanwj@gmail.com>2016-12-19 12:38:35 +0100
committerWladimir J. van der Laan <laanwj@gmail.com>2016-12-19 12:40:01 +0100
commit7f72568e6b15fc139323fb200591a50762f6df0b (patch)
tree85a19f00ca5bd8c88874d3f162d5ca84ac2c95d9 /src/Makefile.am
parenta336d13a587c46470fd6671d558198f299f04a8d (diff)
parent749be013f5cba0bbb01f1f89df77106aea5a4cc1 (diff)
downloadbitcoin-7f72568e6b15fc139323fb200591a50762f6df0b.tar.xz
Merge #9236: Fix races for strMiscWarning and fLargeWork*Found, make QT runawayException use GetWarnings
749be01 Move GetWarnings() into its own file. (Gregory Maxwell) e3ba0ef Eliminate data races for strMiscWarning and fLargeWork*Found. (Gregory Maxwell) c63198f Make QT runawayException call GetWarnings instead of directly access strMiscWarning. (Gregory Maxwell)
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 389be6c058..c7124c3ef9 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -155,6 +155,7 @@ BITCOIN_CORE_H = \
wallet/rpcwallet.h \
wallet/wallet.h \
wallet/walletdb.h \
+ warnings.h \
zmq/zmqabstractnotifier.h \
zmq/zmqconfig.h\
zmq/zmqnotificationinterface.h \
@@ -306,6 +307,7 @@ libbitcoin_common_a_SOURCES = \
scheduler.cpp \
script/sign.cpp \
script/standard.cpp \
+ warnings.cpp \
$(BITCOIN_CORE_H)
# util: shared between all executables.