aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorCory Fields <cory-nospam-@coryfields.com>2014-06-05 14:17:50 -0400
committerCory Fields <cory-nospam-@coryfields.com>2014-06-05 16:05:57 -0400
commit70c71c50ce552c0358679653c04d7cc72a40222c (patch)
tree58ab86ba29a74a21911643c249d6310415db7b23 /src/Makefile.am
parent6b9f0d5554b75fcc24cbce10e16872df3e103226 (diff)
downloadbitcoin-70c71c50ce552c0358679653c04d7cc72a40222c.tar.xz
build: Tidy up file generation output
- Some file generation was still noisy, silence it. - AM_V_GEN is used rather than @ so that 'make V=1' works as intended - Cut down on file copies and moves when using sed, use pipes instead - Avoid the use of top_ and abs_ dirs where possible
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am10
1 files changed, 5 insertions, 5 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index b3e713b9ad..ce12ddcdbd 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -210,16 +210,16 @@ clean-local:
rm -f leveldb/*/*.gcno leveldb/helpers/memenv/*.gcno
.rc.o:
- @test -f $(WINDRES) && $(WINDRES) -i $< -o $@ || \
- echo error: could not build $@
+ @test -f $(WINDRES)
+ $(AM_V_GEN) $(WINDRES) -i $< -o $@
.mm.o:
- $(OBJC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) \
+ $(AM_V_CXX) $(OBJCXX) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) \
$(CPPFLAGS) $(AM_CXXFLAGS) $(QT_INCLUDES) $(CXXFLAGS) -c -o $@ $<
%.pb.cc %.pb.h: %.proto
- test -f $(PROTOC) && $(PROTOC) --cpp_out=$(@D) --proto_path=$(abspath $(<D) $<) || \
- echo error: could not build $@
+ @test -f $(PROTOC)
+ $(AM_V_GEN) $(PROTOC) --cpp_out=$(@D) --proto_path=$(abspath $(<D) $<)
LIBBITCOIN_SERVER=libbitcoin_server.a
LIBBITCOIN_WALLET=libbitcoin_wallet.a