aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorWladimir J. van der Laan <laanwj@gmail.com>2016-01-28 11:08:51 +0100
committerWladimir J. van der Laan <laanwj@gmail.com>2016-01-28 11:28:24 +0100
commit62f2d769e45043c1f262ed45babb70fe237ad2bb (patch)
tree23fc429dc67fc4455d108a5f727e50dbb9571604 /src/Makefile.am
parent20a408ca99dad3cbb8c1cea0fe5c3d52f328061e (diff)
parentd13f65ebac13ec18b7eb55176c31f1404f185c0c (diff)
downloadbitcoin-62f2d769e45043c1f262ed45babb70fe237ad2bb.tar.xz
Merge #7348: MOVE ONLY: move rpc* to rpc/
d13f65e rpc: update inline comments to refer to new file paths (Daniel Cousens) a0eaff8 move rpc* to rpc/ (Daniel Cousens)
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am22
1 files changed, 11 insertions, 11 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index a104a0148d..b1b8ae123e 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -131,9 +131,9 @@ BITCOIN_CORE_H = \
pubkey.h \
random.h \
reverselock.h \
- rpcclient.h \
- rpcprotocol.h \
- rpcserver.h \
+ rpc/client.h \
+ rpc/protocol.h \
+ rpc/server.h \
scheduler.h \
script/interpreter.h \
script/script.h \
@@ -203,12 +203,12 @@ libbitcoin_server_a_SOURCES = \
policy/policy.cpp \
pow.cpp \
rest.cpp \
- rpcblockchain.cpp \
- rpcmining.cpp \
- rpcmisc.cpp \
- rpcnet.cpp \
- rpcrawtransaction.cpp \
- rpcserver.cpp \
+ rpc/blockchain.cpp \
+ rpc/mining.cpp \
+ rpc/misc.cpp \
+ rpc/net.cpp \
+ rpc/rawtransaction.cpp \
+ rpc/server.cpp \
script/sigcache.cpp \
timedata.cpp \
torcontrol.cpp \
@@ -304,7 +304,7 @@ libbitcoin_util_a_SOURCES = \
compat/glibcxx_sanity.cpp \
compat/strnlen.cpp \
random.cpp \
- rpcprotocol.cpp \
+ rpc/protocol.cpp \
support/cleanse.cpp \
sync.cpp \
uint256.cpp \
@@ -322,7 +322,7 @@ endif
libbitcoin_cli_a_CPPFLAGS = $(AM_CPPFLAGS) $(BITCOIN_INCLUDES)
libbitcoin_cli_a_CXXFLAGS = $(AM_CXXFLAGS) $(PIE_FLAGS)
libbitcoin_cli_a_SOURCES = \
- rpcclient.cpp \
+ rpc/client.cpp \
$(BITCOIN_CORE_H)
nodist_libbitcoin_util_a_SOURCES = $(srcdir)/obj/build.h