aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorWladimir J. van der Laan <laanwj@gmail.com>2017-05-31 17:52:10 +0200
committerWladimir J. van der Laan <laanwj@gmail.com>2017-05-31 18:05:06 +0200
commitff3f9a807d46772646740714f87c7e77d1271678 (patch)
tree05608fb0fb49463e9aa652b1e590ed70222aac24 /src/Makefile.am
parent44a17f278a13ee3257b00b30381f591eb09e0165 (diff)
parent18476423fba5d2cadd2b0973e425a6ebedeb66a4 (diff)
Merge #10484: 0.14 Backports
1847642 [Wallet] unset change position when there is no change on exact match (Gregory Sanders) ae479bc build: fix bitcoin-config.h regeneration after touching build files (Cory Fields) 3d395d6 build: remove wonky auto top-level convenience targets (Cory Fields) 4bc99c3 Add missing <atomic> header in clientmodel.h (Jonas Schnelli) 222f377 Set both time/height header caches at the same time (Jonas Schnelli) 7da1337 Declare headers height/time cache mutable, re-set the methods const (Jonas Schnelli) 9ac40e8 Update the remaining blocks left in modaloverlay at init. (Jonas Schnelli) 1e936d7 Reduce cs_main locks during modal overlay by adding an atomic cache (Jonas Schnelli) 0aee4a1 Check interruptNet during dnsseed lookups (Matt Corallo)
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index e8d22313dc..76dbbced6c 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -457,6 +457,14 @@ DISTCLEANFILES = obj/build.h
EXTRA_DIST = $(CTAES_DIST)
+
+config/bitcoin-config.h: config/stamp-h1
+ @$(MAKE) -C $(top_builddir) $(subdir)/$(@)
+config/stamp-h1: $(top_srcdir)/$(subdir)/config/bitcoin-config.h.in $(top_builddir)/config.status
+ $(AM_V_at)$(MAKE) -C $(top_builddir) $(subdir)/$(@)
+$(top_srcdir)/$(subdir)/config/bitcoin-config.h.in: $(am__configure_deps)
+ $(AM_V_at)$(MAKE) -C $(top_srcdir) $(subdir)/config/bitcoin-config.h.in
+
clean-local:
-$(MAKE) -C secp256k1 clean
-$(MAKE) -C univalue clean