aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorCory Fields <cory-nospam-@coryfields.com>2015-10-13 13:40:47 -0400
committerCory Fields <cory-nospam-@coryfields.com>2015-10-13 13:40:49 -0400
commit60af755e56dc08f54c993ce0c044f3ff203b3f59 (patch)
treed128b53877ffdd8c3543526268c3df294ace8d43 /src/Makefile.am
parenta1d623da3ea4c73605d27703bc966ed8109d231e (diff)
downloadbitcoin-60af755e56dc08f54c993ce0c044f3ff203b3f59.tar.xz
build: univalue subdir build fixups
- Force a rebuild if the headers change - Only build the lib target - Clean univalue on 'make clean'
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 605031eb43..0a16a863eb 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -36,8 +36,8 @@ LIBUNIVALUE=univalue/libunivalue.la
$(LIBSECP256K1): $(wildcard secp256k1/src/*) $(wildcard secp256k1/include/*)
$(AM_V_at)$(MAKE) $(AM_MAKEFLAGS) -C $(@D) $(@F)
-$(LIBUNIVALUE): $(wildcard univalue/lib/*)
- $(AM_V_at)$(MAKE) $(AM_MAKEFLAGS) -C univalue/
+$(LIBUNIVALUE): $(wildcard univalue/lib/*) $(wildcard univalue/include/*)
+ $(AM_V_at)$(MAKE) $(AM_MAKEFLAGS) -C $(@D) $(@F)
# Make is not made aware of per-object dependencies to avoid limiting building parallelization
# But to build the less dependent modules first, we manually select their order here:
@@ -421,6 +421,7 @@ EXTRA_DIST = leveldb
clean-local:
-$(MAKE) -C leveldb clean
-$(MAKE) -C secp256k1 clean
+ -$(MAKE) -C univalue clean
rm -f leveldb/*/*.gcno leveldb/helpers/memenv/*.gcno
-rm -f config.h