aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorrandy-waterhouse <noone@yodasan>2014-08-16 16:48:24 +1200
committerrandy-waterhouse <noone@yodasan>2014-08-17 20:22:12 +1200
commitc101c7690706c962944570fe5efe9975bf740a53 (patch)
tree65fc4507d0d9b10a31fed452b961a47a62c65c7a /src/Makefile.am
parentb3ec053082c96233512c076eebc486b16a317b91 (diff)
downloadbitcoin-c101c7690706c962944570fe5efe9975bf740a53.tar.xz
build: Add --with-utils (bitcoin-cli and bitcoin-tx, default=yes).
Help string consistency tweaks. Target sanity check fix.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am6
1 files changed, 2 insertions, 4 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 2c00f8b572..1bb59bce7b 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -55,12 +55,10 @@ if BUILD_BITCOIND
bin_PROGRAMS += bitcoind
endif
-if BUILD_BITCOIN_CLI
- bin_PROGRAMS += bitcoin-cli
+if BUILD_BITCOIN_UTILS
+ bin_PROGRAMS += bitcoin-cli bitcoin-tx
endif
-bin_PROGRAMS += bitcoin-tx
-
.PHONY: FORCE
# bitcoin core #
BITCOIN_CORE_H = \