aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorSuhas Daftuar <sdaftuar@chaincode.com>2015-12-16 14:57:54 -0500
committerWladimir J. van der Laan <laanwj@gmail.com>2016-01-20 13:50:58 +0100
commite25b158ab8812abaad2a83b04db6b821154a6a0f (patch)
tree379e357dd94f4c1c8d29b98631ff90a500190100 /src/Makefile.am
parent64612f182036cf18c1aef45b88fb284c11b35680 (diff)
downloadbitcoin-e25b158ab8812abaad2a83b04db6b821154a6a0f.tar.xz
RPC: indicate which transactions are replaceable
Add "bip125-replaceable" output field to listtransactions and gettransaction which indicates if an unconfirmed transaction, or any unconfirmed parent, is signaling opt-in RBF according to BIP 125. Github-Pull: #7286 Rebased-From: eaa8d2754b48b62cdd07255fc3028feecad0c095
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 5da1a873de..5d7fbb13d2 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -122,6 +122,7 @@ BITCOIN_CORE_H = \
noui.h \
policy/fees.h \
policy/policy.h \
+ policy/rbf.h \
pow.h \
prevector.h \
primitives/block.h \
@@ -239,6 +240,7 @@ libbitcoin_wallet_a_SOURCES = \
wallet/wallet.cpp \
wallet/wallet_ismine.cpp \
wallet/walletdb.cpp \
+ policy/rbf.cpp \
$(BITCOIN_CORE_H)
# crypto primitives library