aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorWladimir J. van der Laan <laanwj@gmail.com>2014-12-19 09:53:43 +0100
committerWladimir J. van der Laan <laanwj@gmail.com>2015-03-06 15:54:53 +0100
commit4414f5ffe130f46becdc75c8e59ee74604e978aa (patch)
tree857dbb3624c21023894060ea030f55f4628432e3 /src/Makefile.am
parent51377c2dbe0d71dad953a43187749a38010d1f1f (diff)
downloadbitcoin-4414f5ffe130f46becdc75c8e59ee74604e978aa.tar.xz
build: Endian compatibility
- Detect endian instead of stopping configure on big-endian - Add `byteswap.h` and `endian.h` header for compatibility with Windows and other operating systems that don't come with them - Update `crypto/common.h` functions to use compat endian header
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index e1d467ff85..da65efa713 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -141,6 +141,8 @@ BITCOIN_CORE_H = \
walletdb.h \
wallet.h \
wallet_ismine.h \
+ compat/byteswap.h \
+ compat/endian.h \
compat/sanity.h
JSON_H = \