aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorCory Fields <cory-nospam-@coryfields.com>2014-11-06 22:43:19 -0500
committerCory Fields <cory-nospam-@coryfields.com>2014-11-19 22:31:10 -0500
commitcdd36c6c5cc309d98f941a4c78d9642c92c1e46f (patch)
treec9353c4c25f1ea004c70af2d2d5fe70c34fb3b81 /src/Makefile.am
parent2cf5f16c25ac81eac3a09c4f15dad9d2154c03d4 (diff)
downloadbitcoin-cdd36c6c5cc309d98f941a4c78d9642c92c1e46f.tar.xz
build: add --with-libs so that libs are optional
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 63f2375c86..0d45203c90 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -49,7 +49,12 @@ BITCOIN_INCLUDES += $(BDB_CPPFLAGS)
noinst_LIBRARIES += libbitcoin_wallet.a
endif
+if BUILD_BITCOIN_LIBS
lib_LTLIBRARIES = libbitcoinconsensus.la
+LIBBITCOIN_CONSENSUS=libbitcoinconsensus.la
+else
+LIBBITCOIN_CONSENSUS=
+endif
bin_PROGRAMS =
TESTS =
@@ -361,6 +366,7 @@ libbitcoinconsensus_la_CPPFLAGS = $(CRYPTO_CFLAGS) -I$(builddir)/obj -DBUILD_BIT
if USE_LIBSECP256K1
libbitcoinconsensus_la_LIBADD += secp256k1/libsecp256k1.la
endif
+endif
CLEANFILES = leveldb/libleveldb.a leveldb/libmemenv.a *.gcda *.gcno