aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorCory Fields <cory-nospam-@coryfields.com>2014-11-05 20:56:45 -0500
committerPieter Wuille <pieter.wuille@gmail.com>2014-11-18 18:06:47 +0100
commit4300876c81c03f90a6f1dfca675e74bc0bcf46a5 (patch)
tree43429d0a4e647c452bc442ef90630574cc862d0c /src/Makefile.am
parent0dc8613864052172447d32338f4492669918cefa (diff)
downloadbitcoin-4300876c81c03f90a6f1dfca675e74bc0bcf46a5.tar.xz
build: secp256k1 as a subdir, since it's required
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am7
1 files changed, 4 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 517bded369..556fd49c0b 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,3 +1,4 @@
+DIST_SUBDIRS = secp256k1
AM_LDFLAGS = $(PTHREAD_CFLAGS) $(LIBTOOL_LDFLAGS)
@@ -32,7 +33,7 @@ LIBBITCOINQT=qt/libbitcoinqt.a
LIBSECP256K1=secp256k1/libsecp256k1.la
$(LIBSECP256K1): $(wildcard secp256k1/src/*) $(wildcard secp256k1/include/*)
- @$(MAKE) $(AM_MAKEFLAGS) -C $(@D) $(@F)
+ $(AM_V_at)$(MAKE) $(AM_MAKEFLAGS) -C $(@D) $(@F)
# Make is not made aware of per-object dependencies to avoid limiting building parallelization
# But to build the less dependent modules first, we manually select their order here:
@@ -334,11 +335,11 @@ CLEANFILES = leveldb/libleveldb.a leveldb/libmemenv.a *.gcda *.gcno
DISTCLEANFILES = obj/build.h
-EXTRA_DIST = leveldb secp256k1
+EXTRA_DIST = leveldb
clean-local:
-$(MAKE) -C leveldb clean
- -$(MAKE) -C secp256k1 clean 2>/dev/null
+ -$(MAKE) -C secp256k1 clean
rm -f leveldb/*/*.gcno leveldb/helpers/memenv/*.gcno
-rm -f config.h