aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorCory Fields <cory-nospam-@coryfields.com>2014-08-26 15:17:18 -0400
committerCory Fields <cory-nospam-@coryfields.com>2014-08-26 15:28:24 -0400
commit9f7f504efca27c7d390f121410846b45c1732761 (patch)
treed73beb39f384db32be6441bbed134c2327e3cd96 /src/Makefile.am
parentf30801afbde7598318a5b03de9812c58a6a34f33 (diff)
downloadbitcoin-9f7f504efca27c7d390f121410846b45c1732761.tar.xz
build: add -DMINIUPNP_STATICLIB for new version
libminiupnpc changed their required static define to the much more sane "MINIUPNP_STATICLIB". Sadly, they don't respect the old "STATICLIB" for back-compat. Define them both since the old one didn't seem to be conflicting anywhere. Also go ahead and split out the cppflags so that they can be applied only where they're needed. This will help us to build dll's from our libs without having their import/export declspecs poisoned.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 655bfc88c3..35fca6570f 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -135,7 +135,7 @@ obj/build.h: FORCE
libbitcoin_util_a-version.$(OBJEXT): obj/build.h
# server: shared between bitcoind and bitcoin-qt
-libbitcoin_server_a_CPPFLAGS = $(BITCOIN_INCLUDES)
+libbitcoin_server_a_CPPFLAGS = $(BITCOIN_INCLUDES) $(MINIUPNPC_CPPFLAGS)
libbitcoin_server_a_SOURCES = \
addrman.cpp \
alert.cpp \