aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorPieter Wuille <pieter.wuille@gmail.com>2014-04-20 17:36:25 +0200
committerPieter Wuille <pieter.wuille@gmail.com>2014-06-21 19:47:39 +0200
commit977cdadea8a77eed04f1f0fd341ba9dedc3fa783 (patch)
tree842e2239a98d6f5c329e639f4ca953e5ea865f82 /src/Makefile.am
parent540ce6aa10996661a62853797538d2a703664ea2 (diff)
downloadbitcoin-977cdadea8a77eed04f1f0fd341ba9dedc3fa783.tar.xz
Add a built-in SHA256/SHA512 implementation.
This also moves the HMAC-SHA512 implementation to sha2.cpp.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index e1542203f8..4e94d47066 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -75,6 +75,7 @@ BITCOIN_CORE_H = \
rpcserver.h \
script.h \
serialize.h \
+ sha2.h \
sync.h \
threadsafety.h \
tinyformat.h \
@@ -152,6 +153,7 @@ libbitcoin_common_a_SOURCES = \
protocol.cpp \
rpcprotocol.cpp \
script.cpp \
+ sha2.cpp \
sync.cpp \
util.cpp \
version.cpp \