aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorCory Fields <cory-nospam-@coryfields.com>2014-06-13 19:19:35 -0400
committerCory Fields <cory-nospam-@coryfields.com>2014-06-16 17:21:34 -0400
commit679240d0e92f71b38cefd23e3d99e8ebf63c2508 (patch)
tree31b055adc3fcd07bb6b58903a590165de90cacce /src/Makefile.am
parent11404af34c5e3d5aa334e1cfd8edee82fb9dc9a4 (diff)
downloadbitcoin-679240d0e92f71b38cefd23e3d99e8ebf63c2508.tar.xz
sanity: add libc/stdlib sanity checks
These are meant to test our back-compat stubs, but they are enabled for all builds for the sake of consistency.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 0a76829197..e1542203f8 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -85,7 +85,8 @@ BITCOIN_CORE_H = \
util.h \
version.h \
walletdb.h \
- wallet.h
+ wallet.h \
+ compat/sanity.h
JSON_H = \
json/json_spirit.h \
@@ -154,6 +155,8 @@ libbitcoin_common_a_SOURCES = \
sync.cpp \
util.cpp \
version.cpp \
+ compat/glibc_sanity.cpp \
+ compat/glibcxx_sanity.cpp \
$(BITCOIN_CORE_H)
if GLIBC_BACK_COMPAT