aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorjtimon <jtimon@blockstream.io>2014-10-21 08:36:09 +0200
committerjtimon <jtimon@blockstream.io>2014-10-27 13:34:25 +0100
commit071473c55c11c267fe1dec898faf4e3286a3916e (patch)
tree96aa02e20a815bd8dd11f78dc5cf9e5cbfe912c6 /src/Makefile.am
parent1bd8a7b2b969f0077882550692505d55724ff867 (diff)
downloadbitcoin-071473c55c11c267fe1dec898faf4e3286a3916e.tar.xz
Build util and common before building server
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am10
1 files changed, 6 insertions, 4 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 42f325e09d..dbefa71fc6 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -36,13 +36,15 @@ LIBBITCOIN_CRYPTO=crypto/libbitcoin_crypto.a
LIBBITCOIN_UNIVALUE=univalue/libbitcoin_univalue.a
LIBBITCOINQT=qt/libbitcoinqt.a
+# Make is not made aware of per-object dependencies to avoid limiting building parallelization
+# But to build the less dependent modules first, we manually select their order here:
noinst_LIBRARIES = \
- libbitcoin_server.a \
- libbitcoin_common.a \
- libbitcoin_cli.a \
+ crypto/libbitcoin_crypto.a \
libbitcoin_util.a \
+ libbitcoin_common.a \
univalue/libbitcoin_univalue.a \
- crypto/libbitcoin_crypto.a
+ libbitcoin_server.a \
+ libbitcoin_cli.a
if ENABLE_WALLET
BITCOIN_INCLUDES += $(BDB_CPPFLAGS)
noinst_LIBRARIES += libbitcoin_wallet.a