aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorPieter Wuille <pieter.wuille@gmail.com>2014-10-26 01:23:23 -0700
committerPieter Wuille <pieter.wuille@gmail.com>2014-11-20 17:22:02 +0100
commit36fa4a78acac0ae6bb0e95c6ef78630120a28bdd (patch)
tree9a9588babc38c2e052441ee6db58c6e4ac1a72e9 /src/Makefile.am
parent5c4dffd188bf82c1965871bdf013b18a61e3d7d0 (diff)
downloadbitcoin-36fa4a78acac0ae6bb0e95c6ef78630120a28bdd.tar.xz
Split up crypto/sha2
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am12
1 files changed, 9 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 0d45203c90..e1e6915185 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -203,10 +203,14 @@ libbitcoin_wallet_a_SOURCES = \
crypto_libbitcoin_crypto_a_CPPFLAGS = $(BITCOIN_CONFIG_INCLUDES)
crypto_libbitcoin_crypto_a_SOURCES = \
crypto/sha1.cpp \
- crypto/sha2.cpp \
+ crypto/sha256.cpp \
+ crypto/sha512.cpp \
+ crypto/hmac_sha512.cpp \
crypto/ripemd160.cpp \
crypto/common.h \
- crypto/sha2.h \
+ crypto/sha256.h \
+ crypto/sha512.h \
+ crypto/hmac_sha512.h \
crypto/sha1.h \
crypto/ripemd160.h
@@ -342,8 +346,10 @@ if BUILD_BITCOIN_LIBS
include_HEADERS = script/bitcoinconsensus.h
libbitcoinconsensus_la_SOURCES = \
core/transaction.cpp \
+ crypto/hmac_sha512.cpp \
crypto/sha1.cpp \
- crypto/sha2.cpp \
+ crypto/sha256.cpp \
+ crypto/sha512.cpp \
crypto/ripemd160.cpp \
eccryptoverify.cpp \
ecwrapper.cpp \