aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorWladimir J. van der Laan <laanwj@gmail.com>2014-05-26 11:38:44 +0200
committerWladimir J. van der Laan <laanwj@gmail.com>2014-06-15 15:38:22 +0200
commitb750cf1fb9b6529ab1761b22947677ca78a2c626 (patch)
treed0afe7a6b7f4a33be306f259af83fa871c29146b /src/Makefile.am
parent0cafb630254c6459ea02f6fc47e1c37bb81a1238 (diff)
downloadbitcoin-b750cf1fb9b6529ab1761b22947677ca78a2c626.tar.xz
Remove cli functionality from bitcoind
As it says on the tin. It was deprecated in version 0.9, and at some point it should be removed. Removes the dependency of bitcoind on libbitcoin-cli.a. Move some functions that used to be shared but are now only used in bitcoin-cli.cpp to that file. After this change, an error is printed (and exit code 1 is returned) when the user tries to send RPC commands using bitcoind.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am1
1 files changed, 0 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 3016be47b9..0a76829197 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -171,7 +171,6 @@ nodist_libbitcoin_common_a_SOURCES = $(srcdir)/obj/build.h
# bitcoind binary #
bitcoind_LDADD = \
libbitcoin_server.a \
- libbitcoin_cli.a \
libbitcoin_common.a \
$(LIBLEVELDB) \
$(LIBMEMENV)