aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorCory Fields <cory-nospam-@coryfields.com>2014-10-31 23:29:12 -0400
committerCory Fields <cory-nospam-@coryfields.com>2014-11-14 16:25:53 -0500
commitab9edbd6b6eb3efbca11f16fa467c3c0ef905708 (patch)
treebf904532ea259aedb390ec74e16479db7905c883 /src/Makefile.am
parent3d3ce7421e11ed693840e04bee4d18fb9d396309 (diff)
downloadbitcoin-ab9edbd6b6eb3efbca11f16fa467c3c0ef905708.tar.xz
script: create sane error return codes for script validation and remove logging
Attempt to codify the possible error statuses associated with script validation. script/types.h has been created with the expectation that it will be part of the public lib interface. The other flag enums will be moved here in a future commit. Logging has also been removed in order to drop the dependency on core.h. It can be re-added to bitcoind as-needed. This makes script verification finally free of application state and boost!
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 8b5d009842..b3b41e3d17 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -112,6 +112,7 @@ BITCOIN_CORE_H = \
script/sigcache.h \
script/sign.h \
script/standard.h \
+ script/script_error.h \
serialize.h \
streams.h \
sync.h \
@@ -235,6 +236,7 @@ libbitcoin_common_a_SOURCES = \
script/script.cpp \
script/sign.cpp \
script/standard.cpp \
+ script/script_error.cpp \
$(BITCOIN_CORE_H)
# util: shared between all executables.