aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorWladimir J. van der Laan <laanwj@gmail.com>2014-01-11 15:22:07 +0100
committerWladimir J. van der Laan <laanwj@gmail.com>2014-01-11 15:23:15 +0100
commit5a407bd095218b38686f965ebd58c7c485a9242d (patch)
tree977c09f49ac2b06b5cb4b9c09be129e3f35b4351 /src/Makefile.am
parent061aff4c46babdc30bb9f52f874a24edd8d14d82 (diff)
downloadbitcoin-5a407bd095218b38686f965ebd58c7c485a9242d.tar.xz
makefile.am: split long lines into one file per line
This makes it easier to read diffs. Cosmetic change to build system only.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am79
1 files changed, 65 insertions, 14 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 85d7c3c9c6..9917be2481 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -3,7 +3,10 @@ include Makefile.include
AM_CPPFLAGS += -I$(top_srcdir)/src/leveldb/helpers/memenv \
-I$(builddir)
-noinst_LIBRARIES = libbitcoin_server.a libbitcoin_common.a libbitcoin_cli.a
+noinst_LIBRARIES = \
+ libbitcoin_server.a \
+ libbitcoin_common.a \
+ libbitcoin_cli.a
if ENABLE_WALLET
noinst_LIBRARIES += libbitcoin_wallet.a
endif
@@ -14,20 +17,60 @@ SUBDIRS = . $(BUILD_QT) $(BUILD_TEST)
DIST_SUBDIRS = . qt test
.PHONY: FORCE
# bitcoin core #
-BITCOIN_CORE_H = addrman.h alert.h allocators.h base58.h bignum.h \
+BITCOIN_CORE_H = \
+ addrman.h \
+ alert.h \
+ allocators.h \
+ base58.h bignum.h \
+ bloom.h \
+ chainparams.h \
+ checkpoints.h \
+ checkqueue.h \
+ clientversion.h \
+ coincontrol.h \
+ coins.h \
+ compat.h \
+ core.h \
+ crypter.h \
+ db.h \
+ hash.h \
+ init.h \
+ key.h \
+ keystore.h \
+ leveldbwrapper.h \
+ limitedmap.h \
+ main.h \
+ miner.h \
+ mruset.h \
+ netbase.h \
+ net.h \
+ noui.h \
+ protocol.h \
rpcclient.h \
rpcprotocol.h \
rpcserver.h \
- bloom.h chainparams.h checkpoints.h checkqueue.h \
- clientversion.h coincontrol.h compat.h core.h coins.h crypter.h db.h hash.h init.h \
- key.h keystore.h leveldbwrapper.h limitedmap.h main.h miner.h mruset.h \
- netbase.h net.h noui.h protocol.h script.h serialize.h sync.h threadsafety.h \
- txdb.h txmempool.h ui_interface.h uint256.h util.h version.h walletdb.h wallet.h
-
-JSON_H = json/json_spirit.h json/json_spirit_error_position.h \
- json/json_spirit_reader.h json/json_spirit_reader_template.h \
- json/json_spirit_stream_reader.h json/json_spirit_utils.h \
- json/json_spirit_value.h json/json_spirit_writer.h \
+ script.h \
+ serialize.h \
+ sync.h \
+ threadsafety.h \
+ txdb.h \
+ txmempool.h \
+ ui_interface.h \
+ uint256.h \
+ util.h \
+ version.h \
+ walletdb.h \
+ wallet.h
+
+JSON_H = \
+ json/json_spirit.h \
+ json/json_spirit_error_position.h \
+ json/json_spirit_reader.h \
+ json/json_spirit_reader_template.h \
+ json/json_spirit_stream_reader.h \
+ json/json_spirit_utils.h \
+ json/json_spirit_value.h \
+ json/json_spirit_writer.h \
json/json_spirit_writer_template.h
obj/build.h: FORCE
@@ -93,7 +136,12 @@ nodist_libbitcoin_common_a_SOURCES = $(top_srcdir)/src/obj/build.h
#
# bitcoind binary #
-bitcoind_LDADD = libbitcoin_server.a libbitcoin_cli.a libbitcoin_common.a leveldb/libleveldb.a leveldb/libmemenv.a
+bitcoind_LDADD = \
+ libbitcoin_server.a \
+ libbitcoin_cli.a \
+ libbitcoin_common.a \
+ leveldb/libleveldb.a \
+ leveldb/libmemenv.a
if ENABLE_WALLET
bitcoind_LDADD += libbitcoin_wallet.a
endif
@@ -108,7 +156,10 @@ AM_CPPFLAGS += $(BDB_CPPFLAGS)
bitcoind_LDADD += $(BOOST_LIBS) $(BDB_LIBS)
# bitcoin-cli binary #
-bitcoin_cli_LDADD = libbitcoin_cli.a libbitcoin_common.a $(BOOST_LIBS)
+bitcoin_cli_LDADD = \
+ libbitcoin_cli.a \
+ libbitcoin_common.a \
+ $(BOOST_LIBS)
bitcoin_cli_SOURCES = bitcoin-cli.cpp
#