aboutsummaryrefslogtreecommitdiff
path: root/qa/rpc-tests/python-bitcoinrpc/setup.py
diff options
context:
space:
mode:
authorGavin Andresen <gavinandresen@gmail.com>2014-03-13 17:51:05 -0400
committerWladimir J. van der Laan <laanwj@gmail.com>2014-03-24 19:14:51 +0100
commitd138598f63cc980c1333e7c63a95b19e6b279025 (patch)
tree6cb03d8cacb23eca0979e4d3bfab888c4b056780 /qa/rpc-tests/python-bitcoinrpc/setup.py
parentd3c3210fa376a9c1ce55c537a3f4439202783624 (diff)
Fix regression tests
Taught bitcoind to close the HTTP connection after it gets a 'stop' command, to make it easier for the regression tests to cleanly stop. Move bitcoinrpc files to correct location. Tidied up the python-based regression tests.
Diffstat (limited to 'qa/rpc-tests/python-bitcoinrpc/setup.py')
-rw-r--r--qa/rpc-tests/python-bitcoinrpc/setup.py15
1 files changed, 15 insertions, 0 deletions
diff --git a/qa/rpc-tests/python-bitcoinrpc/setup.py b/qa/rpc-tests/python-bitcoinrpc/setup.py
new file mode 100644
index 0000000000..b5a217bf93
--- /dev/null
+++ b/qa/rpc-tests/python-bitcoinrpc/setup.py
@@ -0,0 +1,15 @@
+#!/usr/bin/env python
+
+from distutils.core import setup
+
+setup(name='python-bitcoinrpc',
+ version='0.1',
+ description='Enhanced version of python-jsonrpc for use with Bitcoin',
+ long_description=open('README').read(),
+ author='Jeff Garzik',
+ author_email='<jgarzik@exmulti.com>',
+ maintainer='Jeff Garzik',
+ maintainer_email='<jgarzik@exmulti.com>',
+ url='http://www.github.com/jgarzik/python-bitcoinrpc',
+ packages=['bitcoinrpc'],
+ classifiers=['License :: OSI Approved :: GNU Library or Lesser General Public License (LGPL)', 'Operating System :: OS Independent'])