aboutsummaryrefslogtreecommitdiff
path: root/depends
diff options
context:
space:
mode:
authorCarl Dong <contact@carldong.me>2021-03-23 12:59:59 -0400
committerCarl Dong <contact@carldong.me>2021-04-05 11:00:39 -0400
commit7476b46f1893a4858616d2a8456a7c43238851ed (patch)
treee6de72becabe6936d1ec4576b0acb67efae7ebed /depends
parent06d6cf6784421290e6235fe8684d5e08ed6f1b62 (diff)
downloadbitcoin-7476b46f1893a4858616d2a8456a7c43238851ed.tar.xz
guix: Build dmg as a static binary
This relatively easy change eliminates all runtime dependencies (except for the kernel) for dmg, which is the only native build tool that gets put in our output tarballs. This allows much more flexibility when constructing the codesigning environment, and is much more robust.
Diffstat (limited to 'depends')
-rw-r--r--depends/packages/native_libdmg-hfsplus.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/depends/packages/native_libdmg-hfsplus.mk b/depends/packages/native_libdmg-hfsplus.mk
index f9d4b0797f..c7c8adef41 100644
--- a/depends/packages/native_libdmg-hfsplus.mk
+++ b/depends/packages/native_libdmg-hfsplus.mk
@@ -12,7 +12,7 @@ define $(package)_preprocess_cmds
endef
define $(package)_config_cmds
- $($(package)_cmake) -DCMAKE_C_FLAGS="$$($(1)_cflags) -Wl,--build-id=none" -DCMAKE_SKIP_RPATH="ON" ..
+ $($(package)_cmake) -DCMAKE_C_FLAGS="$$($(1)_cflags) -Wl,--build-id=none" -DCMAKE_SKIP_RPATH="ON" -DCMAKE_EXE_LINKER_FLAGS="-static" -DCMAKE_FIND_LIBRARY_SUFFIXES=".a" ..
endef
define $(package)_build_cmds