aboutsummaryrefslogtreecommitdiff
path: root/depends
diff options
context:
space:
mode:
authorJonas Schnelli <dev@jonasschnelli.ch>2020-12-16 13:58:59 +0100
committerJonas Schnelli <dev@jonasschnelli.ch>2020-12-16 13:59:04 +0100
commit6af8a6232b2d5fd1874d215f67749a2a6b498bea (patch)
treef7ca231cb2a566a59de51ae5425edcd5a6dd7898 /depends
parentb440c33179e777bfebb8c12840e06ea691a4868f (diff)
parent267f259c0dfbd348340d49e9a89b8684b994e22a (diff)
downloadbitcoin-6af8a6232b2d5fd1874d215f67749a2a6b498bea.tar.xz
Merge #20650: depends: Drop workaround for a fixed bug in Qt build system
267f259c0dfbd348340d49e9a89b8684b994e22a depends: Drop workaround for a fixed bug in Qt build system (Hennadii Stepanov) Pull request description: This PR drops workaround that was [introduced](https://github.com/bitcoin/bitcoin/pull/4592/commits/1dec09b341f61836147d87656aea7f7be02aab6d) for Qt 5.2.1 for a bug in Qt build system that has been fixed in Qt 5.3.0. The bug reports: - https://bugreports.qt.io/browse/QTBUG-35444 - https://bugreports.qt.io/browse/QTBUG-32519 I've noted this change is a part of the #19716, but I think that a separate commit with the documented reason will benefit it. ACKs for top commit: laanwj: Code review ACK 267f259c0dfbd348340d49e9a89b8684b994e22a jonasschnelli: code Review ACK 267f259c0dfbd348340d49e9a89b8684b994e22a practicalswift: cr ACK 267f259c0dfbd348340d49e9a89b8684b994e22a: patch looks correct Tree-SHA512: b994f94776b4f8bb2f996095c87c7fef55e74d1e64852a890d664275e3739ec890ee388b10baa15445dd24ec7b971ce57d396cb062dbed933c18b6b69525349f
Diffstat (limited to 'depends')
-rw-r--r--depends/packages/qt.mk5
1 files changed, 1 insertions, 4 deletions
diff --git a/depends/packages/qt.mk b/depends/packages/qt.mk
index fdf03e73fc..bf34835e1a 100644
--- a/depends/packages/qt.mk
+++ b/depends/packages/qt.mk
@@ -278,10 +278,7 @@ define $(package)_stage_cmds
$(MAKE) -C src INSTALL_ROOT=$($(package)_staging_dir) $(addsuffix -install_subtargets,$(addprefix sub-,$($(package)_qt_libs))) && cd .. && \
$(MAKE) -C qttools/src/linguist/lrelease INSTALL_ROOT=$($(package)_staging_dir) install_target && \
$(MAKE) -C qttools/src/linguist/lupdate INSTALL_ROOT=$($(package)_staging_dir) install_target && \
- $(MAKE) -C qttranslations INSTALL_ROOT=$($(package)_staging_dir) install_subtargets && \
- if `test -f qtbase/src/plugins/platforms/xcb/xcb-static/libxcb-static.a`; then \
- cp qtbase/src/plugins/platforms/xcb/xcb-static/libxcb-static.a $($(package)_staging_prefix_dir)/lib; \
- fi
+ $(MAKE) -C qttranslations INSTALL_ROOT=$($(package)_staging_dir) install_subtargets
endef
define $(package)_postprocess_cmds