aboutsummaryrefslogtreecommitdiff
path: root/depends
diff options
context:
space:
mode:
authorfanquake <fanquake@gmail.com>2021-05-09 11:32:59 +0800
committerfanquake <fanquake@gmail.com>2021-05-09 13:38:48 +0800
commit469a5bc4fa74d70556cce454efbc38fb7945acd8 (patch)
tree307292279fbc11f9f00dbcaa23e6c7265e99998b /depends
parent5925f1e652768a9502831b9ccf78d16cf3c37d29 (diff)
downloadbitcoin-469a5bc4fa74d70556cce454efbc38fb7945acd8.tar.xz
build: build Boost with -fcf-protection when targeting Darwin
The LLVM Clang we use for cross-compilation supports this option, and it's expected that any builders on macOS will also be using an Apple Clang that supports it.
Diffstat (limited to 'depends')
-rw-r--r--depends/packages/boost.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/depends/packages/boost.mk b/depends/packages/boost.mk
index 0800c63dfc..6b3b293140 100644
--- a/depends/packages/boost.mk
+++ b/depends/packages/boost.mk
@@ -26,6 +26,7 @@ $(package)_config_libraries=filesystem,system,test
$(package)_cxxflags=-std=c++17 -fvisibility=hidden
$(package)_cxxflags_linux=-fPIC
$(package)_cxxflags_android=-fPIC
+$(package)_cxxflags_darwin=-fcf-protection=full
endef
define $(package)_preprocess_cmds