aboutsummaryrefslogtreecommitdiff
path: root/depends
diff options
context:
space:
mode:
authorCarl Dong <contact@carldong.me>2021-03-18 16:20:18 -0400
committerCarl Dong <contact@carldong.me>2021-04-05 11:00:39 -0400
commit06d6cf6784421290e6235fe8684d5e08ed6f1b62 (patch)
treeabf5c623cf47f5612114960cb370348ba8c50792 /depends
parent65176ab5730dff34466caaecdd292625ef8294fc (diff)
downloadbitcoin-06d6cf6784421290e6235fe8684d5e08ed6f1b62.tar.xz
depends: libdmg-hfsplus: Skip CMake RPATH patching
CMake's RPATH patching apparently causes non-reproducibility in the executables which are produced, manifesting in a difference in padding in the .dynstr section (we found this while investigating non-reproducibility in the "dmg" tool). This RPATH patching can be safely skipped for executables which don't depend on internal shared libraries. Documentation sources: 1. https://gitlab.kitware.com/cmake/community/-/wikis/doc/cmake/RPATH-handling 2. https://reproducible-builds.org/docs/deterministic-build-systems/#cmake-notes Prior debugging art: 1. https://stackoverflow.com/questions/63438206/cmake-g-reproducible-build-issue-with-changing-build-path 2. https://github.com/NXPmicro/mfgtools/pull/229/files
Diffstat (limited to 'depends')
-rw-r--r--depends/packages/native_libdmg-hfsplus.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/depends/packages/native_libdmg-hfsplus.mk b/depends/packages/native_libdmg-hfsplus.mk
index 035b767188..f9d4b0797f 100644
--- a/depends/packages/native_libdmg-hfsplus.mk
+++ b/depends/packages/native_libdmg-hfsplus.mk
@@ -12,7 +12,7 @@ define $(package)_preprocess_cmds
endef
define $(package)_config_cmds
- $($(package)_cmake) -DCMAKE_C_FLAGS="$$($(1)_cflags) -Wl,--build-id=none" ..
+ $($(package)_cmake) -DCMAKE_C_FLAGS="$$($(1)_cflags) -Wl,--build-id=none" -DCMAKE_SKIP_RPATH="ON" ..
endef
define $(package)_build_cmds