aboutsummaryrefslogtreecommitdiff
path: root/depends/packages/zeromq.mk
diff options
context:
space:
mode:
authorWladimir J. van der Laan <laanwj@gmail.com>2018-07-10 14:47:48 +0200
committerWladimir J. van der Laan <laanwj@gmail.com>2018-07-10 14:49:02 +0200
commit6c6a3001e51b1679af2f375f158d8c87bbb330bc (patch)
tree41e02a8b1733168f9438f42f5045bd6190a15a17 /depends/packages/zeromq.mk
parentb641f60425674d737d77abd8c49929d953ea4154 (diff)
parent974f0bf8e684696be7796dbf3d48ff0a41f4ac26 (diff)
downloadbitcoin-6c6a3001e51b1679af2f375f158d8c87bbb330bc.tar.xz
Merge #13543: depends: Add RISC-V support
974f0bf8e684696be7796dbf3d48ff0a41f4ac26 depends: Mention RISC-V known compilation issue with gcc-7.3.x (Wladimir J. van der Laan) 0d1f38c45ff40f17b42074e3b58211e794a19edb depends: update zmq config.guess/config.sub for riscv support (fanquake) 409481c46555afb34a038dbc69a8285b83eb952e depends: latest config.sub (fanquake) d7005e9988ddae4d3507963b42c525257c34ddb0 depends: latest config.guess (fanquake) 359e2e352590e1e473da70e28a38d14a068a3103 depends: Add RISC-V support (Wladimir J. van der Laan) Pull request description: This adds support for riscv32 and riscv64 builds to the depends system. The change consists of documentation and build system changes. The most significant change is an update of `config.sub` and `config.guess` inside zeromq patch, as the current version does not recognize the `riscv*` host tuples (there's no new version of ZeroMQ yet with newer ones). Good thing: RISC-V 64-bit toolchain packages can be installed out of the box on Ubuntu 18.04+. I would also like to add RISC-V 64-bit executables to gitian, but this will not be possible until #12511 . Tree-SHA512: 358ed72ee9e4ae44e7d305c09a4ff5ce5460eeb7ed915eb25d39c8f43b61e7b347f51bf0ae5d83ddb4ce8876dea7703c926b3baa3cccb4932b3bc17160d801bb
Diffstat (limited to 'depends/packages/zeromq.mk')
-rw-r--r--depends/packages/zeromq.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/depends/packages/zeromq.mk b/depends/packages/zeromq.mk
index cde523370f..9412c181e6 100644
--- a/depends/packages/zeromq.mk
+++ b/depends/packages/zeromq.mk
@@ -13,7 +13,8 @@ endef
define $(package)_preprocess_cmds
patch -p1 < $($(package)_patch_dir)/0001-fix-build-with-older-mingw64.patch && \
- patch -p1 < $($(package)_patch_dir)/0002-disable-pthread_set_name_np.patch
+ patch -p1 < $($(package)_patch_dir)/0002-disable-pthread_set_name_np.patch && \
+ cp -f $(BASEDIR)/config.guess $(BASEDIR)/config.sub config
endef
define $(package)_config_cmds