aboutsummaryrefslogtreecommitdiff
path: root/depends/packages/qt.mk
diff options
context:
space:
mode:
authorfanquake <fanquake@gmail.com>2022-03-31 10:04:37 +0100
committerfanquake <fanquake@gmail.com>2022-03-31 21:23:38 +0100
commita24ef27cfe6e28979cdc33382d69a979367febff (patch)
tree82eae09904f56591cb1db0248cc0f9fea91ecfc6 /depends/packages/qt.mk
parent1021e4cc6877f66729e01a6662d5877e718ed276 (diff)
downloadbitcoin-a24ef27cfe6e28979cdc33382d69a979367febff.tar.xz
build: patch around qt duplicate symbol issue
This is currently causing the same failure in two different PRs: ```bash duplicate symbol 'lcQpaFonts()' in: /tmp/cirrus-ci-build/depends/x86_64-apple-darwin/lib/libQt5ThemeSupport.a(qgenericunixthemes.o) /tmp/cirrus-ci-build/depends/x86_64-apple-darwin/lib/libQt5FontDatabaseSupport.a(qfontengine_coretext.o) ld: 1 duplicate symbol for architecture x86_64 ``` ```bash x86_64-apple-darwin-ld: error: duplicate symbol: __Z10lcQpaFontsv >>> defined in /tmp/cirrus-ci-build/depends/x86_64-apple-darwin/lib/libQt5ThemeSupport.a(qgenericunixthemes.o) >>> defined in /tmp/cirrus-ci-build/depends/x86_64-apple-darwin/lib/libQt5FontDatabaseSupport.a(qfontengine_coretext.o) ``` Co-authored-by: Hennadii Stepanov <32963518+hebasto@users.noreply.github.com>
Diffstat (limited to 'depends/packages/qt.mk')
-rw-r--r--depends/packages/qt.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/depends/packages/qt.mk b/depends/packages/qt.mk
index 9cdfd21d2c..46587c7a89 100644
--- a/depends/packages/qt.mk
+++ b/depends/packages/qt.mk
@@ -13,7 +13,7 @@ $(package)_patches += dont_use_avx_android_x86_64.patch dont_hardcode_x86_64.pat
$(package)_patches += fix_android_jni_static.patch dont_hardcode_pwd.patch
$(package)_patches += qtbase-moc-ignore-gcc-macro.patch fix_limits_header.patch
$(package)_patches += fix_bigsur_style.patch use_android_ndk23.patch
-$(package)_patches += rcc_hardcode_timestamp.patch
+$(package)_patches += rcc_hardcode_timestamp.patch duplicate_lcqpafonts.patch
$(package)_qttranslations_file_name=qttranslations-$($(package)_suffix)
$(package)_qttranslations_sha256_hash=d5788e86257b21d5323f1efd94376a213e091d1e5e03b45a95dd052b5f570db8
@@ -243,6 +243,7 @@ define $(package)_preprocess_cmds
patch -p1 -i $($(package)_patch_dir)/fix_bigsur_style.patch && \
patch -p1 -i $($(package)_patch_dir)/use_android_ndk23.patch && \
patch -p1 -i $($(package)_patch_dir)/rcc_hardcode_timestamp.patch && \
+ patch -p1 -i $($(package)_patch_dir)/duplicate_lcqpafonts.patch && \
mkdir -p qtbase/mkspecs/macx-clang-linux &&\
cp -f qtbase/mkspecs/macx-clang/qplatformdefs.h qtbase/mkspecs/macx-clang-linux/ &&\
cp -f $($(package)_patch_dir)/mac-qmake.conf qtbase/mkspecs/macx-clang-linux/qmake.conf && \